Error while running filters

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

Error while running filters

Postby battlecat » Fri Aug 10, 2007 5:56 pm

Hi I tried to use the filters button in the wahcade-setup program. Here is the error I have received via the terminal I started the program in:

richard@richard-laptop:~$ wahcade-setup
Traceback (most recent call last):
File "/usr/share/games/wahcade/win_filter.py", line 224, in on_cboLists_changed
self.load_filter()
File "/usr/share/games/wahcade/win_filter.py", line 240, in load_filter
self.create_initial_filter()
File "/usr/share/games/wahcade/win_filter.py", line 310, in create_initial_filter
self.dlgwait_pulse)
File "/usr/share/games/wahcade/filters.py", line 376, in create_initial_filter
f.write('%s\nTrue\n' % (item))
File "/usr/lib/python2.5/codecs.py", line 638, in write
return self.writer.write(data)
File "/usr/lib/python2.5/codecs.py", line 303, in write
data, consumed = self.encode(object, self.errors)
File "encodings/cp1252.py", line 12, in encode
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 5-8: invalid data


I have yet to use Wahcade. I have not been able to get it to list my roms successfully. Any help would be great since I would love to use the program.
User avatar
battlecat
 
Posts: 339
Joined: Fri Aug 03, 2007 12:53 am
Location: Pennsylvania, USA

Postby SeTTleR » Sat Aug 11, 2007 2:54 pm

Hi Battlecat,
there are a few other Threads that deal with the same problem. Are you using the 64 Bit xmame or SDLmame? There are some issues with the mameinfo.xml files created by the 64 Bit Mame Versions.
Take a look around in the forum. Perhaps is there an a way to solve your problem.
SeTTleR
 
Posts: 35
Joined: Sat Jul 28, 2007 8:36 pm

Any solution?

Postby Aaron » Wed Aug 15, 2007 4:40 pm

Battlecat, I'm having the same exact problem. First I tried installing and configuring on Ubuntu Feisty Fawn (32bit) then I formatted the drive and tried w/ Dapper Drake (32) and got the same results. I also tried to manually create the mameinfo.xml file using mame -listxml > /home/aaron/emulators/mame/mameinfo.xml. This made no difference when trying to run the filter generation. I get the same output you do. Have you found a solution?
Aaron
 
Posts: 1
Joined: Wed Aug 15, 2007 8:15 am

Postby balki » Thu Aug 16, 2007 10:31 am

I know it's a huge file, but if Aaron or Battlecat could gzip their mameinfo.xml file and email it to me I'll take a look...

Cheers,

Andy
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Postby battlecat » Sat Aug 25, 2007 3:10 pm

Hi there:

I once more return to this thread because I have not been able to get the filters to generate a game list. I haved this now on 4 machines all running various Linuxs and still no go.

Has anyone come up with something? I just re-downloaded it this morning and tried again with no success.

Thanks
User avatar
battlecat
 
Posts: 339
Joined: Fri Aug 03, 2007 12:53 am
Location: Pennsylvania, USA


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 5 guests

cron