Background Music

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

Background Music

Postby AzaIndustries » Mon Apr 28, 2014 5:15 am

Hey everyone, I'd just like to say Wahcade is awesome. I've been using it for maybe 3 weeks now without problems.
I've searched the forums and used google and can't seem to come up with a solution to my problem.

I'm running lubuntu 14.04 (I think?) 32bit
Wahcade 0.99pre8

I've changed this post to be more background music focused. I've given up on movie snapshots for now.

I have all the background music set up with proper pathing, formats and volume.

But wahcade doesn't output any sound at all, and no terminal errors are appearing.

Does anyone have experience with getting wahcade to play music?
AzaIndustries
 
Posts: 21
Joined: Mon Apr 28, 2014 5:04 am

Re: Background Music

Postby sairuk » Tue Apr 29, 2014 3:21 am

Wahcade 0.99pre8 <-- is old and broken, use Mah!Cade http://www.mameau.com/mahcade/

also refer to Wah!Ki for instructions on common problems, http://wahki.mameau.com/
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: Background Music

Postby AzaIndustries » Wed Apr 30, 2014 1:30 am

Ok thanks a lot, I wasn't aware mahcade was on linux.

EDIT: Did a fresh install after complete removal of old version. Anytime I go to add an emulator I get this crash
Code: Select all
Traceback (most recent call last):
  File "/usr/local/share/games/wahcade/wc_setup.py", line 497, in on_txeEmuListTitle_changed
    idx = int(new_idx)
ValueError: invalid literal for int() with base 10: '1/'


I'll keep googling it and trying to fix it, but so far I can't figure it out.
AzaIndustries
 
Posts: 21
Joined: Mon Apr 28, 2014 5:04 am

Re: Background Music

Postby sairuk » Wed Apr 30, 2014 3:37 am

Thats a new one, interesting please add a bug on launchpad if you can't figure it out.

AzaIndustries wrote:EDIT: Did a fresh install after complete removal of old version. Anytime I go to add an emulator I get this crash
Code: Select all
Traceback (most recent call last):
  File "/usr/local/share/games/wahcade/wc_setup.py", line 497, in on_txeEmuListTitle_changed
    idx = int(new_idx)
ValueError: invalid literal for int() with base 10: '1/'

mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: Background Music

Postby AzaIndustries » Wed Apr 30, 2014 8:40 am

Yeah no luck yet. Music is working now though =D

If I run the setup manager on clean install I get that crash so I just copied over all my previous settings and emulator INI.
The frontend works fine with them still so I can continue my gameing. =D

I'm hesitent to post my bug on there because it might just be me stuffing something up. Old files being left behind from previous install or something?

I assumed 'sudo apt-get purge wahcade' removed everything before I installed the new version. I also deleted all the settings under home/user/.wahcade before the install.

EDIT: I just did something naughty, commenting out line 496 and 497 of wc_setup.py now I can access the setup program.
This little fix will probably come back to bite me in the ass eventually but it's an easy enough fix to revert if stuff goes crazy.
AzaIndustries
 
Posts: 21
Joined: Mon Apr 28, 2014 5:04 am

Re: Background Music

Postby sairuk » Wed Apr 30, 2014 12:53 pm

I also pulled down a new clean Mah!Cade install on a laptop I was setting up tonight just to test. Unfortunately I could not replicate the issue on Linux Mint 16.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 4 guests

cron