Error Message on Xubuntu

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

Error Message on Xubuntu

Postby bonzo » Wed Dec 19, 2007 3:11 am

Hi all. Thanks for the startup guide...that really did help with setup.

I'm using Xubuntu 7.10 here and am getting the following error messages in a "Bug Detected" screen after launching wahcade:


Code: Select all
Traceback (most recent call last):
  File "wahcade.py", line 72, in <module>
    app = WinMain(options)
  File "/home/balki/projects/wahcade/debian/wahcade/usr/share/games/wahcade/win_main.py", line 97, in __init__
    self.gstMusic = gst_media.MusicPlayer()
  File "/home/balki/projects/wahcade/debian/wahcade/usr/share/games/wahcade/gst_media.py", line 205, in __init__
    self.player = GstPlayer(None)
  File "/home/balki/projects/wahcade/debian/wahcade/usr/share/games/wahcade/gst_media.py", line 43, in __init__
    self.player = gst.element_factory_make("playbin", "player")
ElementNotFoundError: playbin


Maybe a dependency issue? Any idea what could be wrong?

Thanks in advance.
bonzo
 
Posts: 2
Joined: Wed Dec 19, 2007 3:05 am

Postby SeTTleR » Wed Dec 19, 2007 9:00 am

Hi,
do you have gstreamer installed? If you want to play movies in Wah!Cade, you have to install gstreamer.
SeTTleR
 
Posts: 35
Joined: Sat Jul 28, 2007 8:36 pm

Postby balki » Wed Dec 19, 2007 7:06 pm

Hi,

You'll also need: python-gst0.10
And possibly: gstreamer0.10-ffmpeg

Cheers,
Andy
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Postby bonzo » Thu Dec 20, 2007 4:36 am

Thanks, guys.

Unfortunately, I'm getting the same messages after these two packages have been installed. Any other possibilities?

Also, is it possible to disable the movies? Would doing so allow Wahcade to start?
bonzo
 
Posts: 2
Joined: Wed Dec 19, 2007 3:05 am

Postby balki » Thu Dec 20, 2007 1:39 pm

You can disable movies by running wahcade-setup, then click on the Movies option on the Wah!Cade tab.
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Postby awesomo » Sun Feb 10, 2008 5:28 am

balki wrote:You can disable movies by running wahcade-setup, then click on the Movies option on the Wah!Cade tab.


Hi, I am having the same problems as the original poster, even with the two recommended packages installed.

How do I go about disabling Movies? There doesn't seem to be an explicit option to do so (I've left the intro and exit movie fields blank). I am running Xubuntu 7.10 Gutsy on an Asus eee PC.

Any help would be great. Thanks.
awesomo
 
Posts: 2
Joined: Sun Feb 10, 2008 5:18 am

Postby balki » Sun Feb 10, 2008 4:37 pm

Hi,

Ooops - Ignore my previous post. The way to disable movie playback is to (a) leave the intro & exit movie options blank, and (b) make sure the "Movie Directory" entry is blank for each emulator (Emulators Tab).

Also, make the "Play Music From" checkbox is unticked in the Music drop-down.

Cheers,
Andy

P.S. Check this post too:
http://www.anti-particle.com/forum/viewtopic.php?t=159
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Postby awesomo » Sun Feb 10, 2008 5:43 pm

Hi, thanks for the quick reply. I am still getting the same error as before.

I installed the following packages from the post you linked:
* gstreamer-0.10-ffmpeg
* gstreamer-0.10-fluendo-mp3
* gstreamer-0.10-plugins-bad
* gstreamer-0.10-plugins-good
* gstreamer-0.10-plugins-ugly

Here are my settings:
In Wah!Cade Tab, Movies drop down:
Intro and Exit Movie fields are blank, Delay secs is 0, Volume 0%
Music drop down:
Play Music From is unchecked, field blank. Volume 0%

In the Emulators (MAME) Tab, Screen saver drop down:
Screen saver type blank screen, Movie Directory blank, External Screen saver blank.
Artwork drop down:
Artwork #1 thru #10 are blank, Movie Directory blank, Movie Artwork #1

Any ideas? Thanks.
awesomo
 
Posts: 2
Joined: Sun Feb 10, 2008 5:18 am

Postby balki » Wed Feb 13, 2008 5:53 pm

Hi,

I've got a work-around for the problem which should at least let you run Wah!Cade...

I'll try and get a quick release out at the weekend. :wink:

Cheers,
Andy
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Postby jfath » Sat Feb 16, 2008 10:07 pm

Installing gstreamer0.10-plugins-base fixed the problem for me.

jfath
jfath
 
Posts: 1
Joined: Sat Feb 16, 2008 10:03 pm


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 1 guest

cron