Page 1 of 1

Tracebacks

PostPosted: Tue Dec 09, 2014 10:13 pm
by battlecat
Hello:

I have been inactive now for a few years. I ended up going back to using an XP box for my arcade cabinet after having the menu crash at parties once to often.

I would like to start reporting in tracebacks and errors as I find them. Is developement still going on with Wah!Cade - Mah!Cade?

Here is my latest traceback
I received this error after doing the following:

  • Fresh updated install of Linux Mint 17 Cinnamon.
  • Downloaded a fresh copy of Mah!Cade from: http://www.mameau.com/mahcade/
  • Opened a CLI and ran the command >> wahcade
  • The version I downloaded was: wahcade.py bzr-devel "mahcade"
--The ouput of running wahcade was:

Twitter Support Disabled, install tweepy (pip install tweepy)
First run, Wah!Cade setting user config profile in: /home/battlecat/.wahcade
Restart after configuring (run wahcade-setup or see the README file).


I then ignored this of course like most users and ran in the CLI >> wahcade

This time I recieved this error code.

Traceback (most recent call last):
File "wahcade.py", line 86, in <module>
app = WinMain(options)
File "/usr/local/share/games/wahcade/win_main.py", line 355, in __init__
self.load_emulator()
File "/usr/local/share/games/wahcade/win_main.py", line 1361, in load_emulator
self.load_list()
File "/usr/local/share/games/wahcade/win_main.py", line 1400, in load_list
self.emu_ini)
File "/usr/local/share/games/wahcade/filters.py", line 318, in create_initial_filter
_catenc = get_file_encoding(_catver_ini)
File "/usr/local/share/games/wahcade/filters.py", line 108, in get_file_encoding
for line in file(filename, 'rb'):
IOError: [Errno 2] No such file or directory: '~/emulators/mame/catver.ini'


I realize that I did not setup any of the parameters for the program. This is just an inelegant fail on behalf of the program. Perhaps it should produce a message informing the user of the need to set the program up and how to do so. Or it might just go into the setup program if it cannot detect a previously set up system?

Anyway I look at it there has to be a way to make the installation and setup process smoother.

Thanks again for your hard work!
BC

Re: Tracebacks

PostPosted: Tue Dec 09, 2014 10:37 pm
by Zombie
Development is still going on with MahCade only. Not WahCade. As for your error, you are missing catver.ini. (I've found that initial out of the box Configs for MahCade don't work. But once configured and all requirements are met Mahcade runs fine.

Re: Tracebacks

PostPosted: Tue Dec 09, 2014 11:00 pm
by battlecat
Thanks Zombie for the reply. Is there any way to improve Mah!Cade's initial setup? Could it be changed so that it does not need a catver.ini to get going?

Throwing errors right away is a good way to scare people off.

Thanks again!
bc

Re: Tracebacks

PostPosted: Wed Dec 10, 2014 2:07 am
by sairuk
Hi battlecat,

Thanks for the report, this is an issue i experienced recently myself after doing a new installation on Mint. The intent is to correct this and start reviewing the code for a potential core review.

Everything is possible given time and resource,

I'm continually running short of both atm as RL work starts to wind down i find myself in the constant search of a new source of income for my family.

Development is continuing, ever so slowly. There is much to capture/improve with the codebase.

Re: Tracebacks

PostPosted: Wed Dec 10, 2014 10:37 pm
by Zombie
Are you still having issues?