ERROR --sync

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

ERROR --sync

Postby RomKnight » Wed Aug 20, 2008 1:05 am

Here I am again...

Every other time i start wahcade it "crashes" so i finally took the time and patience to check what was going and started it by hand several times. After two or three retries after this happened or if i use --sync option it works. After that it's OK again for a few times till it happens again and so on and on...

Because of the word codec there, i'm guessing this has to do with gstreamer (again) because i use an intro movie and it's not related to wahcade but just in case...

I'm on wahcade .99pre2 but it also happens on pre1 and definitely this didn't happen on .27 and nvidia drivers 173.14.12 (i think they're the latest but we're talking about nvidia :D)

Here's the result when it fails to start.

$wahcade

** (wahcade.py:7516): WARNING **: Unknown codec ID 86022, please add here
The program 'wahcade.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 40 error_code 3 request_code 3 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: ERROR --sync

Postby balki » Wed Aug 20, 2008 12:53 pm

Hi RomKnight,

Sounds very much like a gstreamer bug ...
If you remove the intro / exit movie options (using wahcade-setup) does wahcade start OK?

How big is the movie? Any chance you could mail it to me?

Cheers,
Andy

P.S. Sorry for leaving the psyco mis-spelling in :oops:
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Re: ERROR --sync

Postby RomKnight » Wed Aug 20, 2008 7:05 pm

Hi,

No movies no bug. So it seems a gstreamer bug... yet again :evil:

I can email them to you yes.. 10MB each but will you receive them? Just tell me where should I send them.
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: ERROR --sync

Postby balki » Thu Aug 21, 2008 7:59 am

Just send one of them to: wahcade "at" anti-particle "dot" com.

Cheers,
Andy
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Re: ERROR --sync

Postby RomKnight » Fri Aug 22, 2008 2:10 pm

sent. I hope you receive it...
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: ERROR --sync

Postby balki » Fri Aug 22, 2008 5:11 pm

Got it. Thanks. Of course, it plays perfectly on my system - nice video too... :?

I think the best I can do for now is to make the error handling of video / audio playback in wahcade a lot more robust.

If it helps, here's a list of all the gstreamer components that I've installed (Ubuntu Hardy Heron 8.04):
apt-gstreamer.png


Cheers,
Andy
You do not have the required permissions to view the files attached to this post.
User avatar
balki
Site Admin
 
Posts: 425
Joined: Thu Jan 01, 1970 1:00 am
Location: Huddersfield, UK

Re: ERROR --sync

Postby RomKnight » Sat Aug 23, 2008 12:08 am

The video was bigger, I cut it but it's still to big I use it because i'm gona move my wahcade to a cabinet I've bought and its' cool to have intro and exit movies to show off for friends :)

Anyway, I can also see the video perfectly. I just had that on and off problem where I need --sync to start wahcade. I said "had" because now wahcade is always called with --sync.

The only gst-plugins I cant have installed are the "bad" ones. They mess with the my system. There are posts about that here and they don't affect only me or fedora for what i've seen.

But I trust you to solve this as usual, so keep up the good work.

Tiago Fortuna
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: ERROR --sync

Postby battlecat » Sat Aug 23, 2008 12:48 pm

Hi out there:

Just want to add my two cents in here. Thanks RomKnight for all the GStreamer help with the bugs. I don't think I would have figured that one out. I know that many users want to use the video and the audio options of Wah!Cade to enhance the playback. I was wondering if there are any videos that are avaible for use that could be sent along as the default to both the intro - exit video as well as an audio soundtrack to play while the menu is waiting?

It would start to make things easier because if there is a default then we would know of the issues more often than we do now since people might not be bothering to set these options up. In other words I think we are not hearing about the bugs because so many people like myself don't usually set those options up until the very end of the set up if at all.

What do you guys think?

Battlecat
http://www.anti-particle.com - The *nix front end of choice.
http://www.twingalaxies.com - The Official Electronic Scoreboard
User avatar
battlecat
 
Posts: 339
Joined: Fri Aug 03, 2007 12:53 am
Location: Pennsylvania, USA

Re: ERROR --sync

Postby RomKnight » Sun Aug 24, 2008 7:16 pm

As long intro/exit movies/musics are short in both file size and length of video.

Many just want to play and have a nice frontend to work with so i guess this is a step where caution should be taken. Until now, it seem to me people we're unaware of this feature of if they do, they just don't care to use it and this might explain why not many ?bugs? were found.

Maybe a poll on the subject could help.

Cheers,

Tiago
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 5 guests

cron