SNES setup driving me nuts!

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

SNES setup driving me nuts!

Postby englischdude » Wed Dec 29, 2010 11:30 pm

Hi all,

hopefully you can help. I have built an arcade cabinet and at the moment have xubuntu running with Wahcade just fine. The only emulator which I have on there at the moment is MAME, and now I would like to install the snes9x.

1. I have downloaded the snes9x and snes9x gtk packages from the repository.
2. Starting snes9x gtk runs without problem, I can even start games from the gtk frontend
3. Under wahcade setup I have inserted a new emulator. Assigned the executable as /usr/games/snes9x
4. Made a directory /home/user/emulators/snes9x
5. Under home/user/emulators/snes9x I have copied the entire directory structure from home/user/emulators/mame
6. Under /etc/snes9x/snes9x.conf I have set the rompath to /home/user/emulators/snes9x/roms
7. In the wahcade setup I have designated the list generation method as Rom directory.


When I now start up Wahcade, I am greeted with the Mame layout, I can generate a MAME gameslist and play a MAME game as normal. I can also change emlators to the snes, however now games are not listed and when I try to generate a games list it seems to go through the motions but the list is empty.

Can anyone give me any tips as to how I can get this going. I am doing the dummy run on my laptop soas not to screw up my cab.

Thanks in advance for your help.

Regards
Martin
Last edited by englischdude on Thu Dec 30, 2010 12:28 pm, edited 1 time in total.
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm

Re: SNES setup driving me nuts!

Postby sairuk » Thu Dec 30, 2010 12:26 am

Is your rompath and file extension for the snes platform in wahcade set correctly (ie in /home/user/.wahcade/ini/snes.ini)?

everything else sounds fine.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: SNES setup driving me nuts!

Postby englischdude » Thu Dec 30, 2010 12:37 pm

Hi,

here is my /home/user/.wahcade/ini/snes9x.ini file. Seems ok to me!:

### zsnes.ini (wahcade v0.8) ###

emulator_title Super Nintendo

### List Generation Settings ###
rom_path ~/home/user/emulators/snes9x/roms
rom_extension zip
dat_file
nms_file
catver_ini_file
list_generation_method rom_folder

### Execution Settings ###
app__executable ~/usr/games/snes9x
app__commandline_format -fs -sc "[rompath]/[name].[romext]"
emulator_executable ~/usr/games/snes9x
commandline_format -fs -sc "[rompath]/[name].[romext]"
alt_commandline_format_1
alt_commandline_format_2
game_specific_config_path

### Artwork Locations ###
artwork_1_image_path ~/emulators/snap/snes/screens
artwork_2_image_path ~/emulators/snap/snes/boxes
artwork_3_image_path ~/emulators/snap/snes/carts
artwork_4_image_path
artwork_5_image_path
artwork_6_image_path
artwork_7_image_path
artwork_8_image_path
artwork_9_image_path
artwork_10_image_path
movie_preview_path ~/emulators/artwork/movies
movie_artwork_no 1

### Screen-Saver Settings ###
enable_music_in_screensaver 0
saver_type slideshow
movie_path
movie_fullscreen 1
quit_delay 30
wrapper_executable
wrapper_commandline_format [name]
scr_file

### External Application Settings ###
ipc_file_or_path
app_1_executable
app_1_commandline_format
app_2_executable
app_2_commandline_format
app_3_executable
app_3_commandline_format
auto_launch_apps

### Additional Settings ###
music_path
lcd_display_file_path
lcd_fe_text

### Settings used by MAMEWAH ###
current_list 0
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm

Re: SNES setup driving me nuts!

Postby englischdude » Thu Dec 30, 2010 9:07 pm

what about the dat nms and catver files. do I need to designate a filepath to these in the above ini file? If yes, where do I get the files from?
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm

Re: SNES setup driving me nuts!

Postby Zombie » Thu Dec 30, 2010 10:55 pm

snes9x and snes9x-gtk are different emulators. I use snes9x-gtk.
User avatar
Zombie
 
Posts: 791
Joined: Mon Oct 06, 2008 2:52 pm

Re: SNES setup driving me nuts!

Postby englischdude » Fri Dec 31, 2010 10:04 am

hi zombie,

thanks for your post but that does not help me further. To my understanding, snes9x-gtk was a frontend for snes9x. I can get roms running well with snes9x-gtk, but now i want to run snes9x from wahcade.

Is this really such a challenging problem to get snes9x running with wahcade? Is there noone here who has already started snes9x from wahcade that can give me some help?

Regards
Martin
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm

Re: SNES setup driving me nuts!

Postby sairuk » Fri Dec 31, 2010 11:42 am

from the sounds of this issue as described so far, the emulator is not the issue. The ini structure looks fine for generating a listing, providing the rompath and the file extension is correct.

How did you add in snes9x to wahcade, did you add it through the setup screen?

Can you check for the existence of the following files:
~/.wahcade/ini/snes9x.ini <--- you have shown the contents on this file already
~/.wahcade/ini/snes9x-0.ini
~/.wahcade/files/snes9x.fav
~/.wahcade/files/snes9x-0.lst
~/.wahcade/files/snes9x-0.fav

if any of these files do not exist, the gamelist generation will fail. These are created as part of adding the emulator through the wahcade-setup dialog.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: SNES setup driving me nuts!

Postby englischdude » Fri Dec 31, 2010 4:48 pm

Hi Sairuk,

will check this later. In the meantime I tried a workaround using zsnes. that worked like a dream right out of the proverbial box!

Regards
Martin
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm

Re: SNES setup driving me nuts!

Postby Zombie » Fri Dec 31, 2010 4:59 pm

snes9x-gtk is a fork of snes9x, not a frontend. You can disable the GTK interface. Thats what I do.
User avatar
Zombie
 
Posts: 791
Joined: Mon Oct 06, 2008 2:52 pm

Re: SNES setup driving me nuts!

Postby englischdude » Sat Jan 01, 2011 7:31 pm

so got everything working in the end, many thanks to Mike ironfist! The paths were wrong in the ini file. In addition, I should have been pointing to the gtk file.

How is it possible to disable the gtk interface? If i do this, do the wahcade controller setting become default?
englischdude
 
Posts: 17
Joined: Sun Dec 26, 2010 1:33 pm


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 4 guests

cron