Layouts not working?

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

Layouts not working?

Postby the_gamer » Sat Jul 09, 2011 7:26 pm

Hi folks,

I would like to create a different layout for every Emulator. In wahcade-setup I chose fceux and called it nes and snes9x called Super Nintendo. In my layout-directory I had nes.lay and Super Nintendo.lay. I tried that and the snes9x used the nes.lay. I thought it was a problem with the space in the name. So I changed the name to snes in the filename and wahcade-setup. Then the snes9x-layout was working... but the fceux one also uses the snes9x-layout! I renamed it again to supernes. Same issue. I would really like if both would work but they don't. I also have a mame-layout and mame-emulator which worked fine with all, only with those two only one works. Can anybody see why only one of those works and not both? Or give me a hint where I could look to find the problem?

Thanks a lot in advance

Edit: I checked all file permissions, all the same. And for testing I removed the working layout to see what happens with the layout not working... works without changing anything else! So did I find a bug? Please tell me it isn't a bug and I am doing something wrong and what please:(

Edit2: No bug! After analyzing the source i fount out that you don't have to use the name you gave to the emulator but the name wahcade expects the emulator to be. NOT even the name of the emulator you use. So for example if you use fceux the name of the layout has to be fceu.lay The reason one layout worked is if no layout file matchex wahcade uses the first one it finds.

SOLVED
the_gamer
 
Posts: 58
Joined: Wed May 04, 2011 8:45 pm

Re: Layouts not working?

Postby General_Faliure » Tue Jul 12, 2011 3:06 pm

Glad you solved it.

Greetz, Ger.
My Arcade cab: https://goo.gl/photos/yE1KACHryQjCaaCj7
Core 2 duo 8400 @3600, 4 gig mem, Geforce 9500. Mame, Mess, Daphne, and some more.
Mah!cade
User avatar
General_Faliure
 
Posts: 154
Joined: Sat Mar 20, 2010 12:51 pm
Location: Drunen, Netherlands


Return to Wah!Cade

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron