[SOLVED] Disable ALT+Space in LXDE

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

[SOLVED] Disable ALT+Space in LXDE

Postby codefenix » Sun Nov 06, 2011 6:53 pm

I decided to try out LXDE on my Xubuntu build. So far I am quite impressed by its speed compared to XFCE. I'll probably do a clean install with Lubuntu soon as a result.

Problem though... The ALT+Space keyboard combination always brings up the window menu for the active application, no matter what the application is. Press ALT+Space now to see what I'm talking about. As anyone who uses MAME can imagine, this is especially annoying.

I deleted all keyboard combinations under Xubuntu. When I toggle back and forth between window managers, Xubuntu behaves as expected but Lubuntu always insists on bringing up this menu.

I've done some Googling, and discovered that LXDE doesn't have a keyboard shortcut GUI-- it's all done by editing an XML file. When I look at this file, there's nothing that defines this specific combination. It's almost like it's hard-coded into LXDE or something.

I'd really like to avoid redefining my controls as a workaround. I am an IPAC2 user. Reprogramming my IPAC2 in addition to all of my emulators' keys is way beyond what I feel should be a simple fix in the OS.

I'm hoping that our resident Lubuntu/LXDE expert, General Failure, reads this and can provide some pointers. ^_^
Last edited by codefenix on Mon Jan 30, 2012 1:42 pm, edited 1 time in total.
User avatar
codefenix
 
Posts: 219
Joined: Fri Sep 25, 2009 3:45 pm
Location: USA

Re: Disable ALT+Space in LXDE

Postby General_Faliure » Mon Nov 07, 2011 3:21 pm

Hello.

I am not an expert, i just muddle through :P
I never had any problems with this, maybe because i use a minipac.
But i found the option in the XML file:
Open ~./config/openbox/lubuntu-rc.xml in Leafpad and make a copy for safety.
Delete these lines:
<keybind key="A-space">
<action name="ShowMenu">
<menu>client-menu</menu>
</action>
</keybind>

That's line 247 to 251.
Save, restart and Alt+Space doesn't work anymore.

Good luck.
My Arcade cab: https://goo.gl/photos/yE1KACHryQjCaaCj7
Core 2 duo 8400 @3600, 4 gig mem, Geforce 9500. Mame, Mess, Daphne, and some more.
Mah!cade
User avatar
General_Faliure
 
Posts: 154
Joined: Sat Mar 20, 2010 12:51 pm
Location: Drunen, Netherlands

Re: Disable ALT+Space in LXDE

Postby codefenix » Mon Nov 07, 2011 11:25 pm

I found it. Thanks for the reply, GF.

In my file, all of my keybindings for desktop switching, windows, and window switching were all inline with one another. When I didn't know what I was looking for, it never "popped" into view because I never bothered to scroll horizontally (silly me). So it was helpful to know exactly what keybind text to search for, and "A-Space" was it as you pointed out. I deleted all of these keybindings (I don't need them in my cabinet), and all is well. Thanks so much for the help!
User avatar
codefenix
 
Posts: 219
Joined: Fri Sep 25, 2009 3:45 pm
Location: USA


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 1 guest

cron