F16 - Tried launch a game and failed

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

F16 - Tried launch a game and failed

Postby RomKnight » Sat Dec 31, 2011 6:15 pm

Finally got time to try and launch a game and this happened:

Fatal Python error: (pygame parachute) Segmentation Fault
/usr/bin/wahcade: line 4: 24467 Aborted (core dumped) python -m pdb wahcade.py $*

No more info :(

also, when this does not happen:

Traceback (most recent call last):
File "win_main.py", line 661, in on_winMain_key_press
self.launch_auto_apps_then_game()
File "win_main.py", line 938, in launch_auto_apps_then_game
self.launch_game(game_cmdline_args)
File "win_main.py", line 1075, in launch_game
p = Popen(cmd, shell=False)
File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
errread, errwrite)
File "/usr/lib64/python2.7/subprocess.py", line 1228, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory


What have I done?
I configured gens and also Kega in the ini folder to try different emulators and the same happens.

From wahcade.log:
[Sat Dec 31 17:28:34 2011]: //======================= NEW LOG RUN =======================//
[Sat Dec 31 17:28:34 2011]: Wah!Cade updating user config files in: /home/tsf/.wahcade
[Sat Dec 31 17:28:34 2011]: Lock file found: Removing
[Sat Dec 31 17:28:34 2011]: Lock File removed successfully
[Sat Dec 31 17:28:34 2011]: Warning: ScrSaver: Failed to create Video gstreamer objects
[Sat Dec 31 17:28:34 2011]: Selected platform: M.A.M.E.
[Sat Dec 31 17:28:35 2011]: Selected gameslist: All Games
[Sat Dec 31 17:28:35 2011]: Fullscreen mode
[Sat Dec 31 17:28:36 2011]: Playing intro movieTrue
[Sat Dec 31 17:28:41 2011]: ******** Command from Wah!Cade is: /usr/bin/mame -skip_gameinfo snowbros
[Sat Dec 31 17:28:41 2011]: ******** Begin command output
[Sat Dec 31 17:29:04 2011]: Lock file found: Waiting 1
[Sat Dec 31 17:29:05 2011]: Lock time elapsed, removing file
[Sat Dec 31 17:29:05 2011]: Lock File removed successfully


So it launches the game but some file is missing somewhere and that prevent's me to play from wahcade. That same command lauched from anywhere in a shell works.
PS: I tried more stuff that's broken in F16 but i'll keep it for now. I'd rather play 1st :D
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby sairuk » Sun Jan 01, 2012 12:10 am

hrrm will have to look at that as well; *nix systems generally require shell=True for subprocess; you can force that in your offline version until its fixed in launchpad version

latest commit should fix the launch issue;

i still get the parachute issue every other launch as well along with GC object already tracked which I'm still investigating
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: F16 - Tried launch a game and failed

Postby RomKnight » Sun Jan 01, 2012 6:39 am

Please understand I'm not a programmer so it took me a few minutes but I finally got it.

Changing line 1075 in win_main.py from "False" to "True" worked.

Code: Select all
p = Popen(cmd, shell=True)
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby RomKnight » Sun Jan 01, 2012 7:38 pm

Used bzr pull to update. got lucky, it did :)

Now this happens when I try to launch a game:


Traceback (most recent call last):
File "/usr/share/games/wahcade/win_main.py", line 661, in on_winMain_key_press
self.launch_auto_apps_then_game()
File "/usr/share/games/wahcade/win_main.py", line 939, in launch_auto_apps_then_game
self.launch_game(game_cmdline_args)
File "/usr/share/games/wahcade/win_main.py", line 1014, in launch_game
game_opts = self.get_launch_options(opts)
File "/usr/share/games/wahcade/win_main.py", line 947, in get_launch_options
if self.music_enabled and not d['play_music']:
AttributeError: WinMain instance has no attribute 'music_enabled'
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby sairuk » Sun Jan 01, 2012 11:54 pm

you probably pulled 88 which was commited after that was posted.

commit 87 was the launch fix

commit 89 fixed the missing underscores in the music_enabled vars but may introduce other problems :) she ain't stable
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: F16 - Tried launch a game and failed

Postby RomKnight » Mon Jan 02, 2012 12:21 am

yeah, was 88.

89 seems fine (except the intro/exit movies...) but I just tested the emulator launch.
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby sairuk » Mon Jan 02, 2012 12:27 am

RomKnight wrote:89 seems fine (except the intro/exit movies...) but I just tested the emulator launch.


The same behaviour is present in launchpad wahcade , so i need to get a better understanding of the whole media side of wahcade before i'll be able to fix it. There is not ETA with that.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: F16 - Tried launch a game and failed

Postby RomKnight » Mon Jan 02, 2012 3:30 am

Not sure about the behavior you are talking. Intro/exit movies were working.

Anyway its not a deal breaker but its a nice gimmick to have :) . It'll be done when its done. I'm just sorry I can't help more :(
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby sairuk » Mon Jan 02, 2012 4:20 am

RomKnight wrote:Not sure about the behavior you are talking. Intro/exit movies were working.

Anyway its not a deal breaker but its a nice gimmick to have :) . It'll be done when its done. I'm just sorry I can't help more :(


branch mainline wahcade with lp:wahcade to a different directory and let me know if the intro/exit movies are working; they aren't for me
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: F16 - Tried launch a game and failed

Postby RomKnight » Mon Jan 02, 2012 12:47 pm

bzr branch lp:wahcade (v1.0-pre1 "Here we are")

Works out of the box. Still with pygame parachutes... but i'm guessing its because some code needs to be changed to work with this newer version. It's not always anyway.

Also worked until sairuk .87.

Request: can you switch the splash screen to show the devel version?
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: F16 - Tried launch a game and failed

Postby sairuk » Sat Mar 03, 2012 10:58 pm

RomKnight wrote:Request: can you switch the splash screen to show the devel version?


Had a look at this but it will not currently work the way i would like.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 1 guest

cron