New bug/error

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

New bug/error

Postby RomKnight » Tue Jan 03, 2012 12:59 pm

Never seen this one. I'll change the topic title accordingly to be more specific but i need someone to tell me what is this :)

Error in sys.excepthook:
Traceback (most recent call last):
File "/usr/share/games/wahcade/exception.py", line 50, in _info
dialog.set_title(_("Bug Detected"))
File "/usr/lib64/python2.7/gettext.py", line 568, in gettext
return dgettext(_current_domain, message)
File "/usr/lib64/python2.7/gettext.py", line 532, in dgettext
codeset=_localecodesets.get(domain))
File "/usr/lib64/python2.7/gettext.py", line 467, in translation
mofiles = find(domain, localedir, languages, all=1)
File "/usr/lib64/python2.7/gettext.py", line 451, in find
if os.path.exists(mofile):
File "/usr/lib64/python2.7/genericpath.py", line 18, in exists
os.stat(path)
TypeError: must be encoded string without NULL bytes, not str

Original exception was:
Traceback (most recent call last):
File "/usr/share/games/wahcade/win_main.py", line 725, in on_winMain_key_press
self.exit_wahcade()
File "/usr/share/games/wahcade/win_main.py", line 449, in exit_wahcade
self.scrsaver.play_movie(exit_movie,'exit')
File "/usr/share/games/wahcade/win_scrsaver.py", line 164, in play_movie
self.video_player.set_volume(0)
File "/usr/share/games/wahcade/gst_media.py", line 217, in set_volume
self.player.set_volume((volume_level / 100.0))
File "/usr/share/games/wahcade/gst_media.py", line 156, in set_volume
self.player.set_property('volume', volume_level)
TypeError: object at 0x5342370 of type __main__.GstPlayBin2 is not initialized
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: New bug/error

Postby sairuk » Tue Jan 03, 2012 9:05 pm

Looks like a div by zero error when trying to set the volume, ie vol 0 / 100
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: New bug/error

Postby codefenix » Tue Jan 03, 2012 9:21 pm

sairuk wrote:ie vol 0 / 100

Dividing zero by something is not the same as dividing something by zero. The former results in zero, while the latter is undefined. The expression "(volume_level / 100.0)" should therefore be valid if volume_level is 0, resulting in 0.
User avatar
codefenix
 
Posts: 219
Joined: Fri Sep 25, 2009 3:45 pm
Location: USA

Re: New bug/error

Postby RomKnight » Wed Jan 04, 2012 12:39 am

mine is set at 80... and it works.

The error above only happened once so far.
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 3 guests

cron