videos.. again :)

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

videos.. again :)

Postby RomKnight » Wed Sep 25, 2013 12:18 am

Now i'm running on Fedora 19 and no videos.

I'm on mahcade 138 which I've read should've solved the problem presented by another member recently.

I have all the gstreamer packages installed as I always do.

I have run whacade -d and here are:

wahcade.log:

[Wed Sep 25 00:07:26 2013]: //======================= NEW LOG RUN =======================//
[Wed Sep 25 00:07:26 2013]: Wah!Cade updating user config files in: /home/tsf/.wahcade
[Wed Sep 25 00:07:26 2013]: Debug Mode Enabled
[Wed Sep 25 00:07:26 2013]: No custom splash found, loading /usr/share/games/wahcade/pixmaps/wahcade-logo.png
[Wed Sep 25 00:07:26 2013]: Warning: ScrSaver: video objects not created, reverting to images
[Wed Sep 25 00:07:27 2013]: Selected platform: M.A.M.E.
[Wed Sep 25 00:07:27 2013]: Selected gameslist: All Games
[Wed Sep 25 00:07:28 2013]: Fullscreen mode


Console output:
Error: option: [wrap_year_manufacturer_label] for ini file: [/home/tsf/.wahcade/wahcade.ini] not found
Error: option: [wrap_screen_type_label] for ini file: [/home/tsf/.wahcade/wahcade.ini] not found
Traceback (most recent call last):
File "/usr/share/games/wahcade/win_main.py", line 792, in on_winMain_key_press
self.exit_wahcade()
File "/usr/share/games/wahcade/win_main.py", line 455, in exit_wahcade
hal_obj = bus.get_object('org.freedesktop.Hal', '/org/freedesktop/Hal/devices/computer')
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 180, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 278, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files


A couple more things:

- I'm using previously .wahcade from a backup before reinstall due to HDD failure (how lucky am I? :D )
- ESC and mahcade menu option to Exit to Desktop DO NOT work. I have to press Alt+F4 or alt-tab and kill
- What are the "[wrap_screen_type_label]" and "[wrap_screen_manufacturer_label]" warnings?

Its late, I might be missing something :s And it is a fresh install and mahcade was the first thing installed after google-chrome and updates.

PS: Great work and thank you for continuing the support on this excelent piece of software. None is better
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby Zombie » Wed Sep 25, 2013 3:25 am

you need to install python-dbus.
User avatar
Zombie
 
Posts: 791
Joined: Mon Oct 06, 2008 2:52 pm

Re: videos.. again :)

Postby RomKnight » Thu Sep 26, 2013 12:33 pm

We really need to update the install page. I haven't done it in quite a while and had trouble finding on how to use bazaar even :-)

Thanks mate. And yes, i do love my videos :-)


[edit]

NO GO. I already had dbus-python installed but I forced a reinstall. Same thing

wahcade -d
Error: option: [wrap_year_manufacturer_label] for ini file: [/home/tsf/.wahcade/wahcade.ini] not found
Error: option: [wrap_screen_type_label] for ini file: [/home/tsf/.wahcade/wahcade.ini] not found
Traceback (most recent call last):
File "/usr/share/games/wahcade/win_main.py", line 792, in on_winMain_key_press
self.exit_wahcade()
File "/usr/share/games/wahcade/win_main.py", line 455, in exit_wahcade
hal_obj = bus.get_object('org.freedesktop.Hal', '/org/freedesktop/Hal/devices/computer')
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 180, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 278, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files


Then I got my hand on fakehal and fakeahllibs... no go. Wahcade has no "awnswer" but it does find the fake "/org/freedesktop/Hal/devices/computer"

[edit2]

Now i've found out i was missing gstreamer-python somehow. Installed it but I only get a white "square" the size of the video. no video and no sound. but now I have all things gstreamer :( viedos play ok in so it should not be a gstreamer problem, right?)

Here's the error:

Traceback (most recent call last):
File "/usr/share/games/wahcade/win_main.py", line 792, in on_winMain_key_press
self.exit_wahcade()
File "/usr/share/games/wahcade/win_main.py", line 455, in exit_wahcade
hal_obj = bus.get_object('org.freedesktop.Hal', '/org/freedesktop/Hal/devices/computer')
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 241, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 248, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 180, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 278, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files


I always forgot it completely bypasses intro video (it will bypass the exit video as well i guess. but since the exit crashes wahcade nothing is in the logs)
ESCaping or using ALF-F4 do work.. if i d not use -d

Found intro movie file, attempting to play /media/games/arcade/other/mamestart.avi
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby sairuk » Fri Sep 27, 2013 2:11 am

Both those listed errors are the same aren't they? Both refer to HAL, the other options for shutdown was ConsoleKit ... I'll look into capturing the error, I assume it blindly tries to execute whatever HAL commands if python-dbus can be imported, similar to the hidden menu items if it can't import dbus.

There was a required HAL package under ubuntu listed on wahki to stop a previously reported problem although I can't recall if it crashed or just did nothing when it was selected. If you can install the real HAL or equivalent it may work around the problem for now.

http://wahki.mameau.com/index.php?title ... l_Packages

As per the above link, I also have to install a specific gstreamer package for video support but have not tried it under fedora. A list of required packages for fedora when you do get it running would be helpful to others and I'll add it Wah!Ki.

My linux install went down this morning, so I won't be doing much until I get that working again.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: videos.. again :)

Postby RomKnight » Fri Sep 27, 2013 12:44 pm

Well, you can add gstreamer* packages and dbus-python - Yes its reversed :-) to that list. Everything else seems to just work except the above...


Gstramer are not all necessary, it kind of depend on the codecs on want.


I did try find hal packages and ended up with the fake ones (which did not work). There seems to be no -compat packages for this and I,m afraid I'm messing with system stability as I just found out what was causing the freezes after a while of use and that had corrupted the install the first time. 6Gbps data 3 controller... I had to reinstall a couple of libraries because they were corrupted on install, I think even though it all went well until reboot, anyway.

Half was replaced it seems but already wasn't there in 17 it seems. Weird.

I'll try to get around it off. I may even do a reinstall again just to fool proof it. It depends on my health. I'm sick ATM and probably throughout the weekend but who know :-)

I'll let you know off.
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby RomKnight » Wed Oct 09, 2013 6:37 pm

http://stackoverflow.com/questions/9191 ... le-missing

does the above link helps with the dbus message?

I still can't see any videos, either intro/end or "preview". I see a squase loading (size of the video) but it stays white. At least it tries something :)
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby sairuk » Thu Oct 10, 2013 10:20 am

RomKnight wrote:http://stackoverflow.com/questions/9191370/dbus-service-file-missing

does the above link helps with the dbus message?

I still can't see any videos, either intro/end or "preview". I see a squase loading (size of the video) but it stays white. At least it tries something :)


no but ta for the link, i may leech fedora and try it out myself although don't hold your breath. I don't have much time for this project at the moment, that will continue for a while yet.

intro and end videos don't work, the gstreamer code needs to be looked at. Preview videos do once the system is configured appropriately.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: videos.. again :)

Postby RomKnight » Fri Oct 11, 2013 8:17 pm

i'm missing something then... preview videos are not working for me :(

HEY, take your time. It's great just to use this already and I really don't like other fE's. Something is missing on them :)
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby Takenover83 » Sun Nov 17, 2013 11:28 pm

Anyone figure this out? I get the same problem on Raspbian on raspberry pi.
Takenover83
 
Posts: 1
Joined: Fri Nov 15, 2013 9:21 pm

Re: videos.. again :)

Postby sairuk » Mon Nov 18, 2013 8:11 am

Dunno, but for some reason they started working on windows again the other day ..... weird

Be good to document it once we work it out though, need to get my rpi up and running with rasbian i guess
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: videos.. again :)

Postby stealth » Thu Jan 30, 2014 6:04 pm

Maybe this can help ...
With ubuntu the "old" package gtsreamer0.10-fmpeg is needed for preview - All the other packages are like this: gstreamer1.0-something -
For information now avconv replaces ffmpeg (at least in Ubuntu) but unfortunately gstreamer1.0-libav doesn't work with wahcade
A little mamecab OS - Mah!Cade, mame , retroarch - Livemamecab
The live CD can be used for a quick demo or test, Download ISO
stealth
 
Posts: 70
Joined: Tue Jan 01, 2008 6:26 pm

Re: videos.. again :)

Postby RomKnight » Mon Feb 03, 2014 6:51 pm

neither does HAL since fedora 18 or so so i have a crash every time i exit (or a timeout if fakehal is installed)

Still no luck on the video though. Thanks for the tip though.

I really can't get my head around other FE.. I really like wah/mahcade but as linux versions go up things are really starting to get broken, like my s.py script.

I now have to change it and i don't know why it's not working on fedora 20. ARGHHHH
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm

Re: videos.. again :)

Postby stealth » Tue Mar 11, 2014 4:10 pm

Now I'm in the same situation crash at exit "wahcade/win_main.py", line 792" with ubunutu Saucy
I added (HAL ppa)
deb http://ppa.launchpad.net/mjblenner/ppa-hal/ubuntu saucy main
deb-src http://ppa.launchpad.net/mjblenner/ppa-hal/ubuntu saucy main

Without more success

Did you find something ?
A little mamecab OS - Mah!Cade, mame , retroarch - Livemamecab
The live CD can be used for a quick demo or test, Download ISO
stealth
 
Posts: 70
Joined: Tue Jan 01, 2008 6:26 pm

Re: videos.. again :)

Postby RomKnight » Tue Mar 18, 2014 9:37 pm

I installed Fedora 16 again since that PC is used for only emulation...
RomKnight
 
Posts: 103
Joined: Wed Oct 03, 2007 10:52 pm


Return to Wah!Cade

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

cron