mame 164

A nice (keyboard based) front end for Arcade / Console game emulators.

Moderator: battlecat

mame 164

Postby General_Faliure » Fri Oct 16, 2015 1:28 pm

Hello.
I have set up a test system (Linux mint 17.2) with Mame 0.164 and the latest Mahcade from launchpad.
So far i have set up Mame, Colecovision, Atari 7800.
I used to use Mess for Coleco and Atari 7800, but now they work in Mame.
The games start fine, but every time i press esc. for exiting a game or Wahcade i get this error message:
Code: Select all
Traceback (most recent call last):
  File "/usr/local/share/wahcade/win_main.py", line 711, in on_winMain_key_press
    self.launch_auto_apps_then_game()
  File "/usr/local/share/wahcade/win_main.py", line 1028, in launch_auto_apps_then_game
    self.launch_game(game_cmdline_args)
  File "/usr/local/share/wahcade/win_main.py", line 1212, in launch_game
    self.start_timer('joystick')
  File "/usr/local/share/wahcade/win_main.py", line 1822, in start_timer
    self.joystick_timer = gobject.timeout_add(50, self.joy.poll, self.on_winMain_key_press)
AttributeError: 'NoneType' object has no attribute 'poll'
My Arcade cab: https://goo.gl/photos/yE1KACHryQjCaaCj7
Core 2 duo 8400 @3600, 4 gig mem, Geforce 9500. Mame, Mess, Daphne, and some more.
Mah!cade
User avatar
General_Faliure
 
Posts: 154
Joined: Sat Mar 20, 2010 12:51 pm
Location: Drunen, Netherlands

Re: mame 164

Postby sairuk » Sat Oct 17, 2015 1:01 pm

This is appearing more and more, i need to setup a test system myself to try and replicate this. Since i don't run anything these days I don't have it set up to test immediately.
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: mame 164

Postby sairuk » Sat Oct 17, 2015 2:07 pm

commit 159 should address this
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: mame 164

Postby General_Faliure » Sun Oct 18, 2015 7:16 am

Thank you, this fixed the problem.
My Arcade cab: https://goo.gl/photos/yE1KACHryQjCaaCj7
Core 2 duo 8400 @3600, 4 gig mem, Geforce 9500. Mame, Mess, Daphne, and some more.
Mah!cade
User avatar
General_Faliure
 
Posts: 154
Joined: Sat Mar 20, 2010 12:51 pm
Location: Drunen, Netherlands

Re: mame 164

Postby Zombie » Wed Oct 21, 2015 7:35 am

Joypad controls are still unresponsive.
User avatar
Zombie
 
Posts: 791
Joined: Mon Oct 06, 2008 2:52 pm

Re: mame 164

Postby sairuk » Thu Oct 22, 2015 12:10 am

Zombie wrote:Joypad controls are still unresponsive.


Source code is available if you'd like to have a crack at fixing joypad support
mameau - My random bits | Wah!Ki - A Wah!Cade wiki | Mah!Cade - Experimental Wah!cade Branch | ListGen | Lazarus
User avatar
sairuk
 
Posts: 432
Joined: Sat May 22, 2010 12:37 am

Re: mame 164

Postby Zombie » Thu Oct 22, 2015 9:22 pm

I do not know Python to be able to fix it. I'll test and report bugs however.
User avatar
Zombie
 
Posts: 791
Joined: Mon Oct 06, 2008 2:52 pm


Return to Wah!Cade

Who is online

Users browsing this forum: No registered users and 1 guest

cron